DynDeveloper.com

DynDeveloper.com

Sign Up Now! Log In
sendow 1/23/2009 7:35:33 PM

Sending "incomplete" / "partial" account number strings to eConnect

Edit 9/17/15 View the main article for this error here 

 I'm importing PA projects using eConnect 10 and have an unusual circumstance where the client uses GL accounts where not all segments are used completely, and where some accounts segments are left blank.  GP certainly supports this via the UI, but I've never had to deal with this using eConnect and now that I'm getting errors trying I'm wondering if it is possible, or if there is a trick to doing it.

 

 Some examples:

1200-1-123456-123  (full account)

1800-1-123456-___ (last segment blank)

1800-_-______-____ (3 segments blank)

 4000-1-1_____-___ (3rd segment partially used,  4th segment blank)

 

So far I've tried sending the full account string using spaces and dashes to fill out the string, like:

 "4000-1-1     -   "

And I've also tried eliminating the spaces:

"4000-1-1-"

And tried eliminating the trailing dash:

"4000-1-1"

For kicks, I even tried eliminating the dashes:

"400011"

 

All of these generate the same error:

Error Number = 4980  Stored Procedure taPAAccountsSetup  Error Description = Account number string does not exist
Node Identifier Parameters: taPAAccountsSetup            
                      

 

Anyone ever used eConnect to  import these type of "partial" account number strings?

 [:^)]

Version: Unknown or N/A
Section: eConnect