jship 1/31/2011 9:59:45 AM

Problems using DAG.exe

I have added a button to a form via modifier that I need to reference. I am attempting to use the DAG.exe utility to create the assembly that I need, but I am running into issues. It is telling me that the dynamics.set file is an invalid launch file.  Couple of details.  I am running the vs2010 sdk from my laptop and I am using windows virtual machine to run the environment that GP2010 is installed in.  I have tried to copy the DAG.exe utilty up to the vm with no success and tried to copy the dynamics.set and dynamics.dic files to my laptop.  This is my fist time trying to use the DAG.exe utility so I am sure it is just something stupid I am doing.  Here is the command I am running from my laptop. I have copied the .set and .dic files from the vm into a gp2010 directory on my laptop...

dag.exe 0 "C:\Program Files\Microsoft Dynamics\GP2010\Dynamics.set" /M

Here is the error.

Invalid Launch File C:\Program Files\Microsoft Dynamics\GP2010\Dynamics.set

Version: Unknown or N/A
Section: Visual Studio Tools for Dynamics GP

Table Definition Quick Links
All Tables
SOP Tables
RM Tables
GL Tables
POP Tables
HR Tables
PM Tables
UPR Tables
IV Tables
Olympic Tables